Snapchat Lenses Not Working on iPhone 4, 4s, and iPad Mini

How to Fix Snapchat Lenses Not Working on iPhone 4, 4s, and iPad Mini

Find out how to fix Snapchat lens not working on old iOS devices like iPhone 4, 4s, and iPad. It’s annoying when you are the only one who cannot use snapchat lens while everybody having fun with the lenses and filters. Activate and enable all those new Snapchat features including lenses on your iPhone.

Snapchat has released a lot of cool features such as new free lenses, filters, improvements in Chat 2.0, and also the latest one is 3D stickers for video. But how the hell all of those features, mainly lenses are not working on iPhone 4, 4s, and iPad Mini. Well, maybe those iPhones are too old for Snapchat, but we can still make it work by doing these following trick.

Note: Update! Now Snapchat Lenses are supported on iPhone 4S, iPod 5th generation, iPad 2nd generation, and Original iPad Mini devices and above. Read more

How to Fix Snapchat Lenses Not Working on iPhone 4, 4s, and iPod

Let me tell you before we start, to do this trick, we will jail-break the iPhone. Another thing is, make sure that you are running on iOS 8.4 or higher. If you agree, continue to read and follow the following steps: First, of course you need to download the TaiG jailbreak tool to edit the iOS system files. We are gonna fooling the system by telling them the device is not an iPhone 4, 4s, or iPad mini, but it’s iPhone 6. Here’s how to do it

also read:   3 Snapchat-like apps with selfie filters for Android and iPhone

Open the Cydia application and search for the tweak Flex 2. On the tweak page, tap Install and then Confirm to install the tweak. When the tweak has been installed, restart the Springboard and then launch Flex from the Home Screen.

Navigate to the Patches tab and press the Plus icon. You’ll be presented with a list of all your available applications. Locate Snapchat from the list and tap on the icon. In the subsequent screen, tap on Snapchat once again and allow the prompt asking you for permission to process the application. You’ll be redirected to a list of variables available within the Snapchat application. Locate the following values and override them with the ones mentioned:

(BOOL)isIphone6 – TRUE
(BOOL)isLowEndModel – FALSE
(BOOL)isIphone4OrEarlier – FALSE
(BOOL)isIphone – TRUE
(BOOL)isIphone:(id) – TRUE (only for BOOL parameter)
(BOOL)isSlowDevice – FALSE
(BOOL)areLensesSupported – TRUE

also read:   How to play Snap Games

As you can see, we tell the system that the device is iPhone 6 by giving the value true to isIphone6 and give the false value to isIphone4OrEarlier.

Now save the change and then apply it. You can close the Flex app and reboot your old iPhone or iPad mini. When your iPhone back to life again, try to run your Snapchat app and see if the lenses, filters, and other features are available.

Actually the reason why the new features of Snapchat are not working for old iPhone like iPhone 4, 4s, and iPad mini are the hardware is outdated and maybe can’t handle the modern app like Snapchat, that’s why in some point you will see the app will slowing down when you are taking a picture and put some lenses or filters. Well it’s all up to you, if you are not sure, then go back to the normal Snapchat by disable the patch from Flex.

Tell your friends who still got earlier iPhone version to do this trick so they can enable Snapchat’s lenses and filters for iPhone 4, 4s, and iPad Mini.

 

4 thoughts on “Snapchat Lenses Not Working on iPhone 4, 4s, and iPad Mini”

  1. Just because you have an iphone 4 DOES NOT MEAN YOU ARE POOR!!! ?. Seriously I have an iphone 4 and so do other people at my school and my school is like 90% rich people! Iphone 4/4s are actually still very common . Stop calling people poor if they can’t get a better phone yet!! It’s not people fault that there parents are tight arses or they actually like there phone and don’t want to get a new one yet. And PS learn how to spell while your at it ! ? and they are not old iphone 3’s are old . Why else do iphone 4’s actually have resale value?

    Reply
  2. My IOS is 7.1.2 and when I want to download snapchat it tells me uprade to IOS 8.0 and iPhone 4 cannot be upgraded.. what should I do

    Reply

Leave a Reply to admin Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.